UPDUino FPGA workshop

From RevSpace
Revision as of 19:00, 11 April 2019 by Ralph Benadski (talk | contribs) (Prerequisites:)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
Event FPGA workshop
Name FPGA workshop
Contact Ranzbak
Duration 2019-04-13 14:00 - 2019-04-13 17:30
Information


* Location: Overgoo 1, Leidschendam
* Open from: 13:37

FPGA Workshop

I would like to have the first session of the workshop at Revspace, Saturday 13th of April from 14:00 till +- 17:30. Since this is the first time I'm going to give this workshop, I would like to keep it small, and have people provide feedback. So 8 people is the maximal amount of people, if there are enough requests I'm going to do another workshop for more persons.

If you want to take part, please add your name below.

Prerequisites:

  • Installed Icestorm toolchain, that supports the Lattice ICE40UP5K FPGA. For instructions read here or use a script that does the work
  • A micro usb cable
  • A working laptop that can run the Icestorm toolchain (Linux or OSX should be fine, for Windows I don't know#)
  • 4 hours of your time, an Saturday the 13th (There will be some breaks)
  • Some basic knowledge about programming
  1. benadski tried to build the toolchain in windows but failed...

Appreciated:

  • Feedback

If you have your own UPDuino, it's fine to join in, if not you can buy a kit from me for 20 euros, containing :

Topics: (If I can fit them all in)

  • Basic IO
  • Modules
  • Constraint files
  • The clock
  • Using simulation
  • Module parameters
  • Wires registers and variables
  • Arrays
  • Verilog tasks, functions, if statements, and for loops.
  • Building a simple state machine using case statements

Please install the toolchain before showing up

Because the toolchain is pretty big the compiling takes a long time on my core I5 (40 minutes), so having a working toolchain installed before the workshop very useful.

If the toolchain is already installed, and you would like to know if your toolchain will work with the development UPDuino V2, do the following:

$ arachne-pnr -h

This results in the help being printed, containing a list of the supported devices:


    -d <device>, --device <device>
        Target device <device>.  Supported devices:
          384 - Lattice Semiconductor iCE40LP384
           1k - Lattice Semiconductor iCE40LP/HX1K
           5k - Lattice Semiconductor iCE40UP5K
         lm4k - Lattice Semiconductor iCE40LM4K
           8k - Lattice Semiconductor iCE40LP/HX8K
        Default: 1k

FPGA Workshop on github has links and instructions.

Notice the line '5k - Lattice Semiconductor iCE40UP5K', this tells you that the toolchain is good to go. If not try to find a newer version and install it before the workshop.

Attendees

(Nick)Name Has UPDuino V2
Anus Jan Only the board
Benadski Yes
Renze No
pbx No
AnonyMou5e No
hnbr!s No
minicom No
cmpxchg No